$re = '/(\w+).*?(?=\1|$)/s';
$str = 'Auth= bigben.com\\\\Dileja
Server = ringring.com
Config = teststringA[XXXXXXXXXXXXXXXXXXX...until EOL
X]Auth= dingdong.com\\\\Debyyy
Server = testtest.com
Config = teststringB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);