import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " # String with possible escaped chars.\n"
+ " (?<string>\\\"(?:\\\\.|[^\\\"])*\\\")\n"
+ "| # or\n"
+ " # \\r\\n, but outside a string (as it's tested after the string).\n"
+ " (?<newline>\\\\r\\\\n)\n"
+ ")";
final String string = "Input : \"Content1 \\r\\n block\" \\r\\n Contentn2 \\r\\n New conenet \" \\r\\n Conetent 3\"\n"
+ "Input : \"A string can contain \\\"quotes\\\"\" \\r\\n Something else \"\\\" \\r\\n\"\n"
+ "Input : \"Tab = \\t | bell = \\a (\\\"alert\\\") | backslash = \\\\\" \\r\\n \"String 2\" UnquotedString";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}