re = /(?:
# String with possible escaped chars.
(?<string>\"(?:\\.|[^\"])*\")
| # or
# \r\n, but outside a string (as it's tested after the string).
(?<newline>\\r\\n)
)/x
str = 'Input : "Content1 \\r\\n block" \\r\\n Contentn2 \\r\\n New conenet " \\r\\n Conetent 3"
Input : "A string can contain \\"quotes\\"" \\r\\n Something else "\\" \\r\\n"
Input : "Tab = \\t | bell = \\a (\\"alert\\") | backslash = \\\\" \\r\\n "String 2" UnquotedString'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end