#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b"
Local $sString = "p3do" & @CRLF & _
"pedo" & @CRLF & _
"pedophile" & @CRLF & _
"pedophilia" & @CRLF & _
"paedofile" & @CRLF & _
"pedofile" & @CRLF & _
"peeedophilia" & @CRLF & _
"pedophil3" & @CRLF & _
"" & @CRLF & _
"DO NOT CAPTURE" & @CRLF & _
"pedogogy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")