$re = '/\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b/m';
$str = 'p3do
pedo
pedophile
pedophilia
paedofile
pedofile
peeedophilia
pedophil3
DO NOT CAPTURE
pedogogy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);