import re
regex = re.compile(r"\bp+[a@\*]?[e3\*\W_]+d+[\*0o](?:(?:ph|f)il(?:[e3\*\W_]|ia))?\b", flags=re.MULTILINE)
test_str = ("p3do\n"
"pedo\n"
"pedophile\n"
"pedophilia\n"
"paedofile\n"
"pedofile\n"
"peeedophilia\n"
"pedophil3\n"
"p3d0\n"
"ped0\n"
"p*do\n"
"peedo\n\n"
"DO NOT CAPTURE\n"
"pedogogy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")