$re = '/^(?!\'+$)[a-zA-Z\']+(?: +[a-zA-Z\']+)*$/m';
$str = 'John Smith
Steve Mc\'millan
Hill St\'
\'\'\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);