#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d+(?:(?:,\d{3})*(?:\.\d{1,2})?|\.\d+)$"
Local $sString = "1.71" & @CRLF & _
"171" & @CRLF & _
"1.71717171" & @CRLF & _
"171.00" & @CRLF & _
"1770" & @CRLF & _
"1,700" & @CRLF & _
"1,700.00" & @CRLF & _
"1,777,777" & @CRLF & _
"1,777,777.00" & @CRLF & _
"1777777.00" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1,444444,4444444,444444.22" & @CRLF & _
"1,333,333,333.233" & @CRLF & _
"171,00" & @CRLF & _
"1777777,00" & @CRLF & _
"1,00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")