import Foundation
let pattern = #"^\d+(?:(?:,\d{3})*(?:\.\d{1,2})?|\.\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.71
171
1.71717171
171.00
1770
1,700
1,700.00
1,777,777
1,777,777.00
1777777.00
1,444444,4444444,444444.22
1,333,333,333.233
171,00
1777777,00
1,00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)