package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\S+$`)
var str = `match these:
JG2144-141/hello
!
and not
laptop bag
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}