$re = '/^\S+$/m';
$str = 'match these:
JG2144-141/hello
!
and not
laptop bag
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);