re = /^(-?\d+)(\s*(\p{Punct})\s*)\1(\2\1)*$/m
str = '1 - 1 - 1
2 - 2 - 2
3 - 2 - 2 - 2
7 - 7 - 7 - 7
5-5-5-5
1-2-2-2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end