use strict;
my $str = 'Hello world';
my $regex = qr/([[:alpha:]]+)/p;
my $subst = '*\\1*';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";