#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\b((?|(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)[a-z,.]*(?: (\d{2}(?:th|st|nd|rd)?)?[,.])?|(\d{2}) (?:(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)[a-z,.]*)?) (\d{4}))"
Local $sString = "text Mar 20, 2009 text" & @CRLF & _
"text March 20, 2009 text" & @CRLF & _
"text 20 Mar. 2009 text" & @CRLF & _
"text Sep 2010 text" & @CRLF & _
"text Mar 20th, 2009 text " & @CRLF & _
"text Mar 21st, 2009 text" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")