import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b((?|(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)[a-z,.]*(?: (\\d{2}(?:th|st|nd|rd)?)?[,.])?|(\\d{2}) (?:(Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)[a-z,.]*)?) (\\d{4}))";
final String string = "text Mar 20, 2009 text\n"
+ "text March 20, 2009 text\n"
+ "text 20 Mar. 2009 text\n"
+ "text Sep 2010 text\n"
+ "text Mar 20th, 2009 text \n"
+ "text Mar 21st, 2009 text\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}