re = /^(?=.*\bgood foo\b)(?!.*\bgood koo\b).*$/m
str = 'some text good foo and some text and good koo
good foo and some text (no indication of koo)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end