import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(255)\\.(0|128|192|224|240|248|252|254|255)\\.(0|128|192|224|240|248|252|254|255)\\.(0|128|192|224|240|248|252|254|255)";
final String string = "255.0.0.0 \n"
+ "255.128.0.0 \n"
+ "255.192.0.0 \n"
+ "255.224.0.0 \n"
+ "255.240.0.0 \n"
+ "255.248.0.0 \n"
+ "255.252.0.0\n"
+ "255.254.0.0\n"
+ "255.255.0.0\n"
+ "255.255.128.0\n"
+ "255.255.192.0\n"
+ "255.255.224.0\n"
+ "255.255.240.0\n"
+ "255.255.248.0\n"
+ "255.255.252.0 \n"
+ "255.255.254.0 \n"
+ "255.255.255.0 \n"
+ "255.255.255.128\n"
+ "255.255.255.192 \n"
+ "255.255.255.224 \n"
+ "255.255.255.240 \n"
+ "255.255.255.248 \n"
+ "255.255.255.252 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}