# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(255)\.(0|128|192|224|240|248|252|254|255)\.(0|128|192|224|240|248|252|254|255)\.(0|128|192|224|240|248|252|254|255)"
test_str = ("255.0.0.0 \n"
"255.128.0.0 \n"
"255.192.0.0 \n"
"255.224.0.0 \n"
"255.240.0.0 \n"
"255.248.0.0 \n"
"255.252.0.0\n"
"255.254.0.0\n"
"255.255.0.0\n"
"255.255.128.0\n"
"255.255.192.0\n"
"255.255.224.0\n"
"255.255.240.0\n"
"255.255.248.0\n"
"255.255.252.0 \n"
"255.255.254.0 \n"
"255.255.255.0 \n"
"255.255.255.128\n"
"255.255.255.192 \n"
"255.255.255.224 \n"
"255.255.255.240 \n"
"255.255.255.248 \n"
"255.255.255.252 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.