const regex = /UC[FPTACL]{1,2}[0-9]{3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('UC[FPTACL]{1,2}[0-9]{3}', 'gm')
const str = `UCF123
UCP123
UCT123
UCFL123
UCFC123
UCFA123
UCPA123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}