$re = '/UC[FPTACL]{1,2}[0-9]{3}/m';
$str = 'UCF123
UCP123
UCT123
UCFL123
UCFC123
UCFA123
UCPA123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);