$re = '/(?<=\d),(?=[\d,]*-)/m';
$str = '6,7- dihydro-1,1,2,3,3-pentamethyl-4(5h)-indanone
steareth-10, polyacrylamide c1,14 isoparaffin, laureth-7, propylene glycol, hydrolyzed soy protein, aloe barbadensis, 1,2-hexanediol
1,1,2,3,3';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;