# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\d),(?=[\d,]*-)"
test_str = ("6,7- dihydro-1,1,2,3,3-pentamethyl-4(5h)-indanone\n"
"steareth-10, polyacrylamide c1,14 isoparaffin, laureth-7, propylene glycol, hydrolyzed soy protein, aloe barbadensis, 1,2-hexanediol\n\n"
"1,1,2,3,3")
subst = "-"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.