const regex = /^(?:\+45|\(\+45\)|\(0045\)|0045|(?!00))\d{8}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+45|\\(\\+45\\)|\\(0045\\)|0045|(?!00))\\d{8}$', 'gm')
const str = `+4512345678
(+45)12345678
004512345678
(0045)12345678
12345678
00451234
004512345678
004612345678
12345678
00441234
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}