use strict;
my $str = '+4512345678
(+45)12345678
004512345678
(0045)12345678
12345678
00451234
004512345678
004612345678
12345678
00441234
';
my $regex = qr/^(?:\+45|\(\+45\)|\(0045\)|0045|(?!00))\d{8}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}