use strict;
my $str = 'https://www.chytryhonza.cz/hypotecni-kalkulacka?v=iTBDcj1Zi0eb4mSEPe3k3CNWhpqvaZmAyRTmCq%2Be1j085RJkWNTwLmXX8mRWLjvUDUxgpyVpx0VS0q08qi%2FTIvRBMeiXW4w9fK%2F8cQg4wXlsDubtLGXAdytQCNC2LTfF
https://www.chytryhonza.cz/hypotecni-kalkulacka?v=
https://www.chytryhonza.cz/srovnavac
https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=dd
https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=1qC3j5r%2BHim0K68IAcodRMrYv6ikx0NneJC39H2oOdl2H8QZ5DL9glGwRtkQSV%2BhVT0c%2B95YLTSmA4BDugvpUQkWIDUmTmv4rcg1t78EMid9jhDOoHh%2BXxRZAxYBGKkB
https://www.chytryhonza.cz/hypoteka
https://www.chytryhonza.cz/hypoteka#aca30160bd78b
https://www.chytryhonza.cz/americka-hypoteka
https://www.chytryhonza.cz/refinancovani-hypoteky
https://www.chytryhonza.cz/zivotni-pojisteni
https://www.chytryhonza.cz/zivotni-pojisteni#a967acb438905
';
my $regex = qr/https:\/\/www\.chytryhonza\.cz\/(zivotni-pojisteni).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}