$re = '/https:\/\/www\.chytryhonza\.cz\/(zivotni-pojisteni).*/m';
$str = 'https://www.chytryhonza.cz/hypotecni-kalkulacka?v=iTBDcj1Zi0eb4mSEPe3k3CNWhpqvaZmAyRTmCq%2Be1j085RJkWNTwLmXX8mRWLjvUDUxgpyVpx0VS0q08qi%2FTIvRBMeiXW4w9fK%2F8cQg4wXlsDubtLGXAdytQCNC2LTfF
https://www.chytryhonza.cz/hypotecni-kalkulacka?v=
https://www.chytryhonza.cz/srovnavac
https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=dd
https://www.chytryhonza.cz/srovnavac-zivotniho-pojisteni?v=1qC3j5r%2BHim0K68IAcodRMrYv6ikx0NneJC39H2oOdl2H8QZ5DL9glGwRtkQSV%2BhVT0c%2B95YLTSmA4BDugvpUQkWIDUmTmv4rcg1t78EMid9jhDOoHh%2BXxRZAxYBGKkB
https://www.chytryhonza.cz/hypoteka
https://www.chytryhonza.cz/hypoteka#aca30160bd78b
https://www.chytryhonza.cz/americka-hypoteka
https://www.chytryhonza.cz/refinancovani-hypoteky
https://www.chytryhonza.cz/zivotni-pojisteni
https://www.chytryhonza.cz/zivotni-pojisteni#a967acb438905
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);