package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(ABC)|123)+$`)
var str = `ABC123
123ABC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}