$re = '/^(?:(ABC)|123)+$/m';
$str = 'ABC123
123ABC';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);