$re = '/^(?:\d{1,3}\.){3}\d{1,3}$/m';
$str = '192.168.1.1
192.168.1.100
10.1.1.1
https://github.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);