re = /^(?:\d{1,3}\.){3}\d{1,3}$/m
str = '192.168.1.1
192.168.1.100
10.1.1.1
https://github.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end