import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\s).{0,20}(?<!\\s)$";
final String string = "123456789012345678901234567890\n"
+ "123456789012345678\n"
+ "123456789012345678901\n"
+ " 1234567890\n"
+ "1234567890 \n"
+ " 1234567890 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}