$re = '/^(?!\s).{0,20}(?<!\s)$/m';
$str = '123456789012345678901234567890
123456789012345678
123456789012345678901
1234567890
1234567890
1234567890
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);