package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\+?91\d{8}`)
var str = `+9110101010`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}