$re = '/\+?91\d{8}/';
$str = '+9110101010';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);