#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)-\s*(?<what>.*):.*?(?<device>ip(?:hone|ad(?: ?air)?))\s*(?<model>\d)?.*ios\s*(?<os>\d)"
Local $sString = "1. Automated - Under the Hood: iPhone 6 running iOS 9" & @CRLF & _
"2. Automated - AU/NZ: iPhone 6 running iOS 9" & @CRLF & _
"3. Automated - DRM: iPhone 6 running iOS 9 " & @CRLF & _
"4. Automated - Ads regression: iPhone6 running iOS 9" & @CRLF & _
"5. Automated - Ads regression: iPhone 5 running iOS 8 " & @CRLF & _
"6. Automated - UI & Functional Regression: on iPad 2 running iOS 8" & @CRLF & _
"7. Automated - Under the Hood: iPad Air on iOS 8" & @CRLF & _
"8. Automated - AU/NZ: iPad Air running iOS 8" & @CRLF & _
"9. Automated - DRM: iPadAir running iOS 8"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")