import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-\\s*(?<what>.*):.*?(?<device>ip(?:hone|ad(?: ?air)?))\\s*(?<model>\\d)?.*ios\\s*(?<os>\\d)";
final String string = "1. Automated - Under the Hood: iPhone 6 running iOS 9\n"
+ "2. Automated - AU/NZ: iPhone 6 running iOS 9\n"
+ "3. Automated - DRM: iPhone 6 running iOS 9 \n"
+ "4. Automated - Ads regression: iPhone6 running iOS 9\n"
+ "5. Automated - Ads regression: iPhone 5 running iOS 8 \n"
+ "6. Automated - UI & Functional Regression: on iPad 2 running iOS 8\n"
+ "7. Automated - Under the Hood: iPad Air on iOS 8\n"
+ "8. Automated - AU/NZ: iPad Air running iOS 8\n"
+ "9. Automated - DRM: iPadAir running iOS 8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}