$re = '/(?<=https:\/\/twitter\.com\/username\/).*/';
$str = 'https://twitter.com/username/status/ID';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);