re = /(?<=https:\/\/twitter\.com\/username\/).*/
str = 'https://twitter.com/username/status/ID'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end