using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([1-9][\d\-\s,]*[0-9])\)";
string substitution = @"<span class=""ref"">$1</span>";
string input = @"Headaches, intracranial hypertension, papilledema and exophthalmos may occur with intracranial infiltration.(7-15, 8)
(234---345)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}