# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Jessip Daggerheart is attempting to sneak up on (?<Player>\w+)/warn ${Player}/gm;t' <<< "\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven't noticed... You should warn them!
"