const regex = /Jessip Daggerheart is attempting to sneak up on (?<Player>\w+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Jessip Daggerheart is attempting to sneak up on (?<Player>\\w+)', 'gm')
const str = `\\#FFFF00Jessip Daggerheart is attempting to sneak up on Aditu, but they haven't noticed... You should warn them!
`;
const subst = `warn ${Player}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);