using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(5000(\.0)?|([0-4]?\d?\d?\d)(\.\d)?)$";
string input = @"4553.4";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}