const regex = /^(?!.*(\d)(?:.*\1){6})(?!.*(\d)\2{4})\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(\\d)(?:.*\\1){6})(?!.*(\\d)\\2{4})\\d+', 'gm')
const str = `112112111
45622222
2343425
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}