$re = '/^(?!.*(\d)(?:.*\1){6})(?!.*(\d)\2{4})\d+/m';
$str = '112112111
45622222
2343425
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);