import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([a-zA-z0-9\\-]*(\\/){1})[a-zA-z0-9\\-\\.]*)((\\:[0-9]{1,5})((\\/)[a-zA-Z0-9\\-]*){0,1}){0,1}$";
final String string = "serviceType/instanceName:1235";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}