$re = '/^(([a-zA-z0-9\-]*(\/){1})[a-zA-z0-9\-\.]*)((\:[0-9]{1,5})((\/)[a-zA-Z0-9\-]*){0,1}){0,1}$/';
$str = 'serviceType/instanceName:1235';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);