package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[^:]+:\s*https?:\/\/[^\s]+$`)
var str = `Example: http://www.example.com/
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}