const regex = /^[^:]+:\s*https?:\/\/[^\s]+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^:]+:\\s*https?:\\\/\\\/[^\\s]+$', '')
const str = `Example: http://www.example.com/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}