$re = '/display\h*:\h*none\h*;?/';
$str = '<div style="display: none; someotherstyle: freaky; etc ...">
Some Content
</div>
But I\'d also like to compensate for discrepancies such as case sensitivity, white space between the components (eg. display : none ;) and omission of the trailing semicolon (ie. display:none)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);