// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"display\h*:\h*none\h*;?").unwrap();
let string = "<div style=\"display: none; someotherstyle: freaky; etc ...\">
Some Content
</div>
But I'd also like to compensate for discrepancies such as case sensitivity, white space between the components (eg. display : none ;) and omission of the trailing semicolon (ie. display:none)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}